Write a python program that will take a string as input from the user and will print the UPPERCASE letters only, if 3 consecutive UPPERCASE letters are found, otherwise it will print all the lowercase letters only. We can assume that the string will always contain both UPPERCASE and lowercase

Computer Networking: A Top-Down Approach (7th Edition)
7th Edition
ISBN:9780133594140
Author:James Kurose, Keith Ross
Publisher:James Kurose, Keith Ross
Chapter1: Computer Networks And The Internet
Section: Chapter Questions
Problem R1RQ: What is the difference between a host and an end system? List several different types of end...
icon
Related questions
Question
Write a python program that will take a string as input
from the user and
will print the UPPERCASE letters only, if 3 consecutive
UPPERCASE letters
are found, otherwise it will print all the lowercase
letters only. We can
assume that the string will always contain both
UPPERCASE and lowercase
letters.
[You cannot use any built in functions except input(),
print(),
len(String), ord(String), chr(int)]
Sample Input 1:
This is CSE110
Sample Output 1:
TCSE
Explanation 1:
The string that the user has given as input here 'This
is CSE110' does have
3 consecutive UPPERCASE letters 'CSE' as we can
see. Thus our program
prints the UPPERCASE letters only which are 'TCSE'.
Transcribed Image Text:Write a python program that will take a string as input from the user and will print the UPPERCASE letters only, if 3 consecutive UPPERCASE letters are found, otherwise it will print all the lowercase letters only. We can assume that the string will always contain both UPPERCASE and lowercase letters. [You cannot use any built in functions except input(), print(), len(String), ord(String), chr(int)] Sample Input 1: This is CSE110 Sample Output 1: TCSE Explanation 1: The string that the user has given as input here 'This is CSE110' does have 3 consecutive UPPERCASE letters 'CSE' as we can see. Thus our program prints the UPPERCASE letters only which are 'TCSE'.
Expert Solution
steps

Step by step

Solved in 2 steps with 3 images

Blurred answer
Recommended textbooks for you
Computer Networking: A Top-Down Approach (7th Edi…
Computer Networking: A Top-Down Approach (7th Edi…
Computer Engineering
ISBN:
9780133594140
Author:
James Kurose, Keith Ross
Publisher:
PEARSON
Computer Organization and Design MIPS Edition, Fi…
Computer Organization and Design MIPS Edition, Fi…
Computer Engineering
ISBN:
9780124077263
Author:
David A. Patterson, John L. Hennessy
Publisher:
Elsevier Science
Network+ Guide to Networks (MindTap Course List)
Network+ Guide to Networks (MindTap Course List)
Computer Engineering
ISBN:
9781337569330
Author:
Jill West, Tamara Dean, Jean Andrews
Publisher:
Cengage Learning
Concepts of Database Management
Concepts of Database Management
Computer Engineering
ISBN:
9781337093422
Author:
Joy L. Starks, Philip J. Pratt, Mary Z. Last
Publisher:
Cengage Learning
Prelude to Programming
Prelude to Programming
Computer Engineering
ISBN:
9780133750423
Author:
VENIT, Stewart
Publisher:
Pearson Education
Sc Business Data Communications and Networking, T…
Sc Business Data Communications and Networking, T…
Computer Engineering
ISBN:
9781119368830
Author:
FITZGERALD
Publisher:
WILEY